MatterControl 1.6 pausing for 1500ms during printing

  • I'm a first time user of MatterControl and I'm using v1.6 on Mac OSX on a Core i7 iMac with 8GB RAM. When I first got started, the app took several minutes to start up the first time I ran it, but now it starts up immediately (I didn't do anything to cause this change in behavior).

    Now, during printing, about every 1-2 minutes the printer pauses for about 1,500ms and then continues. This ends up leaving small blobs of filament sprinkled throughout out the print. I was formerly using Cura and did not encounter this issue, so I don't think it's a printer problem per se.

    I'm running a PrintrBot Simple Metal over USB (/dev/tty.usbmodemFA14311) at 250,000 BAUD (auto-detected).

    Is there anything I can do to remedy the pausing behavior?

    Many thanks!



  • I ran into similar problems on my Windows 10 machine. One time I noticed that the printer paused when the disk activity on my Windows 10 laptop was very high. I got rid of the processes that caused the high disk usage and everything started working again. On a different occasion I ended up backing up and deleting my app data folder, Starting up MatterControl with a fresh database seemed to have solved the second issue. You can always look at the Terminal windows and see, if MatterControl sends messages during the pausing of the printer. That will help isolating the cause. I am using a SeeMeCNC Rostock Max 2 v2.

  • I have exactly those problems. iMac Core i7 OSX, Delta with Marlin firmware (also tried latest 1.1 RC7 marling firmware). Also v1.5 had this problem. I hoped that with 1.6 the problem would be fixed. I want to use mattercontrol because of it's features but printing over USB is terrible. Always stopping and giving blobs in the print.

    The cause: Mattercontrol is (like other apps) reading the temps of the bed and nozzle during printing. Every time the temps are read the printer stops for 0.5 seconds leaving a blob on my print.

    Exporting from Mattercontrol and printing the gcode using pronterface or any other 3d printing app (which also read the temps) results in a perfect print. Somehow the serial communication from Mattercontrol on a Mac is slow (MONO layer).

    I dont like Cura but it does the job without blobs.


    So please Mattercontrol team fix this problem.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.