Version 1.6.0 "Send" file command not working



  • I just installed the new version on my Mac and my LCD controller (not the newest T10 model, the older one). When I have a model on screen and in the Queue I used to be able to select Send from the More.... menu and it would put the file up in the controller ready to view and print. That's not working now. What I'm having to do instead is send the file to the Cloud folder and then import it from there into the controller, which is a nuisance. Anyone else seeing this problem? Anyone have a fix?

    (Also, it's not emailing me and sending a picture when the print completes, even though the boxes are checked and address is entered as before.)

    Seems to be two bugs in the new version.

    Thanks.



  • The controller emailed me a photo on a print now, so apparently that was just a temporary failure before.

    I'd still like to fix the thing about the SEND command not working as before. It used to be so nice to have the sent file just show up in the controller, ready to print, without having to go through the Cloud nuisance.


  • Moderator

    What color is the connection indicator in the top right of MatterControl on the Mac? Sending does not work when the indicator is yellow, only when it is green.



  • Interesting - it's yellow and I'd never noticed that colored dot before. Clicking around I saw a Sync Dashboard command and tried that. Still yellow.

    I will say that when I make changes to MatterControl on the Mac or the controller they change things back and forth automatically. Like if I select a different print quality or turn on/off support material. If I then walk to the other room the change has automatically shown up on the other machine.

    I'm a little vague on the whole connection thing anyway. I have two copies of my printer showing up in the Send dialog window. One's available and one isn't. It's always been like that. I suppose one is the controller and one is the actual printer, and the controller overrides because it's plugged into the printer. Just guessing.

    Now I need to go research this yellow dot thingy. Unless you're kind enough to clue me in:-)



  • I guess I was dreaming on the back and forth settings being automatic. Maybe they went with the print job I sent.

    Anyway, I'm still trying to learn about the green/yellow connection color dot. I've been searching the Touch documentation and MatterControl website and the web in general. No luck yet.

    I'd like to know what it means by being yellow and the hover text saying "Connection Status: Limited Connectivity" and how I get it to change.



  • Nope, not dreaming after all. Right now I'm walking back and forth between rooms and every time I make a change from Low resolution printing to Medium resolution or back the other way I can walk into the other room and the Touch controller is updating the Mac, or vice versa. Full bidirectional communication, even though the MatterControl colored square connection indicator is yellow on the Mac. I still don't know how to change it from yellow to green and I'm coming up blank on the internet searching.


  • Moderator

    I'm glad you are enjoying the new sync functionality. This was the biggest new feature in 1.6.

    Sorry, we are still fleshing out the documentation. A yellow indicator basically means not everything is working right. We have noticed that both Mac and Linux are having trouble, and addressing this issue will be a top priority next week. In the mean time, you can always transfer files through the cloud library.

    I understand your confusion with the two printers in the send dialog. One of them is your MatterControl Touch, and the other is your PC. Since you have selected the same printer on both devices, the same printer shows up in the list twice.



  • Excellent. Like we said, there's a workaround for now. Also, I'm glad to hear I'm not the only one seeing this and that it's being addressed.

    And thank you very much for the feedback. It's very helpful to have an idea what's going on instead of sitting here confused.

    Documentation would help a lot, even if it isn't polished and you just release it as a tech note in your online articles as tips 'n tricks.



  • Yay! The newest update 1.6.1 fixed the Send command from the Mac to the Touch controller. Thank you for working the issue.

    I still have the yellow indicator upper right near my login name, but things are working, so .....

    -Jeff



  • Spoke too soon. It worked twice. Now not working again. I noticed earlier I only saw one printer in the list for the Send command. Now I'm seeing two. One's available and one isn't. The Send command seems to work on both, but nothing shows up at the controller.


Log in to reply
 

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.