Jerky communication between MatterControl on a Windows 10 PC and a Rostock Max II printer

  • Yesterday I was able to print without any issues on my Rostock Max II. Today not so much. The printer was jerking with a very regular pattern. I started the print in MatterControl. The hot end moved a few steps and stopped for a second or two, moved again and stopped. And so on.

    I opened the Terminal Window and found the following pattern:

    Pauses after the following line numbers:

    2696 35
    2731 35
    2766 35
    2801 35
    2836 35
    2871 35


    After 35 lines of GCode commands the PC paused sending new commands to the printer. Then another 35 lines, pause, 35 lines, pause, ...

    Here is a list of failed attempts to fix it:

    1) Uninstall and Reinstall MatterControl

    2) Unplug the Printer from the power supply.

    3) Use a different physical USB port on the laptop to plug the printer in.

    4) Use a different USB cable.

    Here is a list of ideas for what else to try:

    1) Reset the Rambo board (I need to figure out how to do that)

    2) Reload the Rambo firmware

    3) Delete the Printer Profile in MatterControl and create it from scratch again.

    4) Use a different PC (Windows 7) with MatterControl to see, if it is a printer issue or a PC issue.

    What else should I try to troubleshoot this issue?

    I also noticed that the MatterHackers Rambo v2 driver has different UART settings in the Device Manager than the Printer Profile has. I might play with that as well.

  • I created a video that shows the terminal and the printer doing the 35 step dance:

  • I might also try to install the Rambo Driver that SeeMeCNC published. I am almost thinking that the USB driver version and the Rambo firmware version are out of sync.

  • Thanks for your post. We're not sure exactly what to make of this yet, but the development team is looking into the behavior.

    Can you send a print log to us?

  • Thanks Ryan,

    I was able to print a test cube using MatterControl version 1.4. I also looked at the Rostock Rambo Board EPROM settings and found something really interesting. The max. jerk setting is set to 35. 35 is also the number of lines of commands before it "jerks". I bet it's just a total coincident. I'll try printing later tonight and generate the log file, if I still see the strange behavior.


  • Interesting coincidence, but I think that's all it is.

    We look forward to your results.

  • Hi Ryan,

    I just sent the terminal log and the line numbers where the printer paused to Both lists are in the attached excel workbook.
    This time I printed the calibration cube and instead of 35 lines there were 32 to 34 lines between pauses. It almost seems like a buffer/serial communication/driver/firmware issue.

    I used yesterday's 1.6 Alpha build for my test that I ran this morning.

    Thanks for helping,


  • I took this video while trying to print the calibration box. The terminal log that I submitted for analysis was created while capturing this video.

  • Here are the terminal log the numbers where the printer paused while printing the calibration cube.

    Line Numbers with Pauses Number of lines between Pauses
    2312 33
    2345 33
    2378 33
    2411 33
    2445 34
    2478 33
    2511 33
    2545 34
    2577 32
    2610 33
    2643 33

  • I found the solution to my problem. I guess my database must have been corrupt. I closed MatterControl, renamed the MatterControl folder (C:\Users\$USERNAME$\AppData\Local\MatterControl) and restarted MatterControl. After that the printer worked without any jerking or stuttering.

  • I'm glad that you found the problem. I know this might sound like a stupid question, but when was the last time you rebooted MatterControl or your laptop? I only say this because I have had experience with communication being jerky like this, and it was because my PC was running out of memory. It turns out that MatterControl's memory usage goes up and rarely goes back down (every time I view a 3D model, or it's g-code, memory goes up, even if I view the same model repeatedly), eventually I need to reload it or even reboot my whole machine before I get smoothness again.

  • I think @Lochemage may be on to something. The jerky behavior has been hypothesized to be related to memory problems, so closing MatterControl might just reset any affected memory and dissipate the symptoms temporarily. I'd expect the behavior to return after memory issues show themselves again.

  • Thanks guys for your feedback.

  • MatterHackers

    Hey tellingmacine, thanks for all the hard work looking at this bug. We were able to figure out exactly what it is and it will be fixed in MatterControl 1.6.

    Actually, it is already fixed! Try the alpha. :

  • Hi Lars,

    the Alpha is already installed and printing PokeBall bottoms. I am liking all the new features!!!!

    Thanks again for your great support!!!!

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.