After I do a print-I can no longer manually control printer - have to connect - reconnect

  • Before I start a print, i can manually control the printer. That is, I can use the Controls to turn on/off the heaters / move the carriage, etc, or send commands via the terminal. But, after I do a print, and either the print completes normally or i cancel it, I no longer can manually control the printer. If I send another file to print, it prints it, so the program itself is still communicating with the printer, but, the manual controls become disabled. To gain manual control again I have to Disconnect and Reconnect.

    This has been like this since I first starting using Matter Control - which has only been about 4 months.

    The printer is a Rostock Max V1, my PC runs Win 10 64 bit

    Anyone else have this issue, or is it just me?

  • What version of Repetier firmware is on your machine? Can you post a print log after a print has completed and you've tried to do some moves?

  • Repetier firmware is 92.9

    When I opened the Terminal after the print is complete, or after I hit cancel, I see that goes into a loop Resend 10

    Below is a snip after I hit cancel


    <-ok 7 [16.499]
    <- [16.499]
    ->N8 M105*47 [16.499]<-ok 8 [16.503]<- [16.503]
    <-T:144.24 /0 B:54.74 /0 B@:0 @:0 [16.503]
    <- [16.503]
    ->N9 M114*46 [16.503]
    <-ok 9 [16.507]
    <- [16.507]
    <-X:0.00 Y:0.00 Z:378.750 E:0.0000 [16.507]
    <- [16.507]
    ->Communication State: Connected
    <-Error:Missing linenumber
    <- <- <- <-Resend:10 <- <-ok <- <- <- <-Resend:10 <- <-ok <- <- <- <-Resend:10 <- <-ok <- <- <- <-Resend:10 <- <-ok <- <- <- <-Resend:10

  • This is a known issue with certain versions of Repetier.

    It should be fixed in the latest version. If it is not possible to update your firmware, you should be able to get around it by adding the following line to your custom End G-Code and Cancel G-Code.

    M110 N0

  • Hey, Thanks. That worked - I was thinking there must be some g-code i could used - this worked.

    I don't look forward to updating the Repetier firmware. The original printer used a Rambo board, and when the board fried I used a spare Ramps 1.4 I had (I use the Ramps 1.4 to control my CNC I made). I had to made a few changes to the firmware to get it all working correctly with the Ramps card. Which it does BTW.

  • Oops I spoke too quickly. Adding M110 N0 to the End or Cancel code worked the first time - and once in a while. But, most of the time it has introduced a new problem. Now most of the time it does into a Homing Loop and keeps trying to home the machine until i hit Disconnect.

    If updatinig the Repetier firmware will resolve this, then I will have to do it

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.