No 3D preview in Windows version (resolved)

  • UPDATE: Partially resolved, see below

    Hi everyone,

    I use MatterControl on a Mac that is connected to my 3D printer, and it works fine but it's an old Mac and super slow.

    I thought I'd install the Windows version on my high-end PC so that I could export some gcode on a faster machine and then just use the Mac to print them, however after installing the Windows version I don't get any 3D previews and that is preventing me from viewing the models to make some small tweaks to their scale.

    Does MatterControl have to connect to a printer in order for it to generate the previews and let me manipulate them?

    Thanks for any tips!

  • By default, MatterControl is supposed to display 3D graphics without a printer connected. You need to have a printer *selected* but don't necessarily have to be connected in order to slice a model, but 3D graphics should still work.

    That said, it sounds like something's not right. Either the 3D graphics card in your computer isn't rendering properly or MatterControl isn't using it. The funny thing is that usually MatterControl usually just crashes if it can't work with the existing card-- the fact that you're able to run the program without 3D graphics and without a crash is odd.

    What kind of graphics card does your computer have?

    Also, you didn't mention it (plus you just installed on Windows so it doesn't seem likely that you even know about it), but just to cover all possibilities: can you confirm that you are not disabling 3D graphics using the target modifier as shown in this FAQ?:

  • Thanks for the reply!

    I did not disable 3D graphics. It's a fresh/new install of MatterControl with no changes made.

    The graphics card is an Nvidia GTX 1080.

    Also, the plot thickens: This doesn't seem to be a 3D rendering issue in general. I just launched it again and tried to view some of the models that come with the library, and sure enough they work.

    I then tried one of the models I'd hoped to be working on, and they don't display for some reason. And then I tried loading one of those same models, but one I'd loaded into MatterControl while on the Mac and saved out again after scaling it. Guess what? It displays.

    So for some reason it's just not displaying this certain set of STL files I downloaded (which display fine in MC on my Mac)...

    I will continue to investigate. Of course, if anyone has any thoughts in the meantime, let me know!



  • Update: Interestingly, although these STL files worked on the Mac, I had to open and resave them in OpenSCAD before MatterControl on Windows would let me see them.

    Not sure if that's something "wrong" with the windows version, or just a weird quirk of these files.

    In anyone is interested in troubleshooting the files in question came from here:

  • Thanks for reporting back.

    My guess is that it has something to do with the way the original files were created. If you're noticing that the problem is isolated to a group of files all from the same source then the issue is probably with that source. Geometry is difficult for some programs to generate correctly, and bad geometry is notorious for causing problems with the way models are rendered in MatterControl. Essentially, the model files must be pretty close to perfect for MatterControl to accept and display them properly.

    If I ever have any trouble getting models to display correctly in MatterControl, I run them through netFabb:

    It's a model repair service (now) owned by Microsoft, and it does a great job of fixing any problems related to the geometry of the model. Once I do that models usually show up fine in MatterControl.

    Keep us updated if you come up with anything new.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.