MatterControl on Ubuntu 16.04

  • Hello.

    I use MatterControl 1,5 on ubuntu 16.04.

    The program works correctly only if I run it with administrator privileges from a terminal.

    If I run a program with a shortcut it can not connect to the printer, can not connect to my account MatterControl and closes when generating gсode.

    How do I make a normal start with a program shortcut?

    Sorry if the translation is not entirely understandable.

  • It sounds like your user does not have permissions to access the serial port. To fix this, all you have to do is run...

    $ gpasswd -a $USER dialout

    Then log out and log back in.

    Here are more tips on using MatterControl on Linux.

  • Thanks, that helped. But I need to add sudo:

    sudo gpasswd -a $USER dialout

    log out and log back in - did not help, it started to work only after a reboot

  • It remains one problem - program is closed when generating gcode new objects or existing after changing.

    When starting from the terminal it works (with admin rights).

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.