Can't Re-enable Auto Leveling

  • Using MatterControl 1.5.3

    I was printing a large piece and it the filament jammed hours into the print. I saved the Gcode and found the next layer to print and edited the file so that it would start printing where it left off. The problem was that auto leveling was enabled and factored into the gcode so when i went to print it MatterControl tried to again apply the leveling offsets and the head would be too high. I finally figured out I had to Turn Auto Leveling OFF for this print.
    In OPTIONS->Calibration-<Software Print Leveling I switched the button to OFF.

    This worked and i was able to complete the print seemlessly (can't even see where it had stopped).

    BUT Problem is, I have closed and restarted MatterControl, and now want to print a New object. I go to :OPTIONS->Calibration-<Software Print Leveling and it shows "(disabled)" But the On/Off button no longer shows. The only button is the CONFIGURE button. There is no way to re-enable the auto leveling using the points i had previously set. I can edit those points, and tried editing and Saving - but that doesn't Enable the feature, it still shows '(disabled)' And the Auto Level symbol doesn't show up on next to the Temp at the top. The only way to re enable it, it seems, is to re CONFIGURE. I am using the 13 point leveling, so that is a hassle just to re enable it. and right now the settings were perfect. So, i will have to re-do it and make sure i set to the same settings...

    But, this appears to be a bug - the On Off button should not disappear when you want to temporarily disable the feature

  • It sounds like Requires Leveling To Print is enabled in the Printer settings. This function will disable the On/Off switch in the OPTIONS menu.

  • Ryan.lutz - Yes, thank you, that is all that it was. Kinda odd though that a setting to require leveling would remove the button to enable leveling. Yo can set it so Leveling is required, but then the button to Enable it is no longer there... Very odd.

    I unchecked it when i printed with Leveling disabled. Obviously the first thing i did was to set Require Leveling back on, then i went to enable leveling... and there wasn't a button there to enable it. Again, that is odd behavior. But, thanks anyway for pointing that out

  • @unltdsoul Thanks for the feedback. I'll make a note for the development team to review this behavior for the next version; hopefully we can find a better workflow.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.