MCT problem updating Launcher software



  • Just got a MatterControl Touch to use with my Rostock MAX 3D printer kit. Tablet has working WiFi set up.

    Main interface shows a red "1" on the Updates link. When I click on it displays on screen "Launcher: Update Ready to Install".

    Every time I click on it it switches to "No Update Available". Then when I go back to previous screen, goes back to showing that 1 update is available.

    Have turned tablet off and back on several times, which did not help. Switched tablet from Dalvik to ART and re-tried, then back again, still no success.

    Was successful in downloading and installing an available update to the MatterControl software.

    Software versions:

    OS: Android 4.4.4

    MatterControl: 1.4.1.5565

    Launcher: 0.0.1.5476



  • This is a known issue caused by a faulty version of the Launcher (0.0.1.5476). Contact support@matterhackers.com and we'll send you a link so you can download and install the newest version.



Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.