CTC Extruder Hammering Front of Printer

  • Ok, we're making progress. The Makerbot and Flashforge use different On Connect G-Code.

    Makerbot Replicator 2:

    M92 X88.8 Y88.8 Z400 E101 ;sets steps per mm for x3g driver
    M206 X285 Y150 Z0 ;sets bed offset (opposite values of bed size)

    Flashforge Creator Pro Dual:

    M92 X94.5 Y94.5 Z400 E96 ;sets steps per mm for x3g driver
    M206 X230 Y155 Z0 ;sets home offset (opposite values of bed size)

    The M92 and M206 commands tell the printer how it is calibrated and how big it's bed is. This explains why your printer was trying to move too far when you had the Makerbot profile selected. So stay with the Flashforge profile for now.

    Now, in order to fix your other issue, Please add the following line to the end of your Start G-Code.

    M190 S[bed_temperature]

    Apparently, when the bed is heated before homing, it causes the printer to get confused about where it is. By adding that line, it forces the printer to home before it starts heating the bed, which prevents the issue. We are still attempting to fully understand this bug, and will hopefully have a permanent fix in the next version of MatterControl.

  • Awesome! I'll give it a try in a bit and report back. Thanks!

  • Much better! I actually tried FlashForge Creator Pro Dual this time and I added the code you gave me to the end. It's printing now. It sits for a long time after preheating before it starts printing. Any idea what that is all about?


  • Wait.. I spoke too soon. I had to cancel the print job. When I hit cancel, instead of stopping, the bed lowered, and the extruder went to the back right corner and kept extruding and making weird noises.

  • Any ideas?

  • The long wait before printing is an issue we have heard of before, and we are still investigating.

    For the problem when canceling, I will have to consult with our Makerbot expert. He is out of the office right now and probably won't be back until next week.

  • Thanks.

  • I really wanted to use MC, but the software just doesn't work well with my CTC. 😞
    I never got even one good print. 😞

  • administrators

    This post is deleted!

  • Sorry. We tried to replicate your issue using our Flashforge Creator Pro, but we were not able to do it. Maybe there is some difference between the Flashforge and the CTC that we are not aware of. Without having one here for testing, there is not much we can do.

Log in to reply

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.