M119 sees FSRs but G29 does not?

  • Hey guys, I've been digging all around online and not finding much. I'm trying to get FSRs working on my Mini Kossel Pro with Johan's FSR fork of Marlin. I've connected all 3 FSR (in parallel) to the Z_MIN pin (gry wire in the harness going to the end effector) and a M119 shows that it recognizes the FSRs in both states. I've tried it with Z_MIN_ENDSTOP inverted and regular. The problem appears as if G29 is not seeing the end stop (even though M119 is). When I start a G29 the end effector drops to about 20mm from the print surface then shifts over to the first probe point, then It slowly moves down toward the bed but when it touches the bed it just keeps trying to go down and crashes as if its not seeing the input from the FSRs. The FSRs are responding to M119 pretty uniformly with light pressure from my finger tip all around the bed. Any thoughts on what I should check next?

    note: I also tried connecting the FSRs to the heated bed thermistor input and got the same results.

Looks like your connection to MatterHackers Community was lost, please wait while we try to reconnect.