FREE, FAST SHIPPING IN THE U.S.
CUSTOMER SERVICE +1 (949) 613-5838

Flashforge Inventor build plate no longer regulating (overheating) set temp.


  • Working with the new Flashforge Inventor. Have had great luck and produced several nice prints. Seemingly out of no where the build plate started to peak, and then overheat. (>130°c).

    • I have updated the firmware as a first line of defense to no avail.
    • I have run the volt meter and noted the build plates power is now always on and read 24v.
    • Sensor wires are all intact and drawing 3v across the build plate and at contact points.
    • Front display and slicers (both Simply3D and FlashPrint) read current and changing temp.
    • Printer still holds until build plate is at temp, then prints (both when heating and cooling)

    So my current thinking is something in the control board is not toggling the build plate power in turn failing to regulate the heat. Seems like it failed to "Open" and now won't turn off.

    I am now leaning to something hardware related, since the rest of the software responses (temp reading, start delays on heating/cooling, and temp warnings) are all intact and responding. Any help or insight is appreciated!



  • flashforge inventor 1 build plate overheat 1 overheating build plate 1
    2
    Posts
    250
    Views
    Log in to reply


  • Your assessment is correct. These are the signs that one of the MOSFETs on the controller board has shorted out. If you inspect the board you may be able to find some visible damage to one of the chips. If you are good with SMD soldering and you have a hot air station, then you may be able to replace the component. Otherwise you are looking at buying a new controller board.


flashforge inventor 1 build plate overheat 1 overheating build plate 1
2
Posts
250
Views
Log in to reply